Rover 216 SE starting issues

Having problems with your 200 or 400? This is the place for asking advice and help on technical problems. Resident experts will be on hand to help you keep your car in tip top condition

Moderator: Forum Staff

Post Reply
Message
Author
7thFebfree
Posts: 1
Joined: Fri Jan 17, 2020 1:06 pm

Rover 216 SE starting issues

#1 Post by 7thFebfree » Thu Feb 13, 2020 5:07 pm

thanks for your response , it’s definitely a Honda engine
Last edited by 7thFebfree on Fri Feb 14, 2020 4:20 pm, edited 1 time in total.

Cromp85
Club Member
Posts: 318
Joined: Fri Oct 02, 2015 11:24 am
Location: Dudley, West Midlands

Re: Rover 216 SE starting issues

#2 Post by Cromp85 » Thu Feb 13, 2020 5:48 pm

Is you engine Honda or Rover?
They both use different ignition systems so it will help to confirm which one.
My Rovers to date:
1994 Rover 220GSI in Tahiti blue (On the road)
2002 MG ZR 105 in Solar red (On loan)
1995 214i (On SORN)

User avatar
GTiJohn
Club Chairman
Posts: 4474
Joined: Mon Aug 16, 2010 8:01 pm
Location: Midlands
Contact:

Re: Rover 216 SE starting issues

#3 Post by GTiJohn » Thu Feb 13, 2020 6:25 pm

216SE = SD3?

if so, it's an S-series...
I like Twin Cams.... and Single Cams

Cromp85
Club Member
Posts: 318
Joined: Fri Oct 02, 2015 11:24 am
Location: Dudley, West Midlands

Re: Rover 216 SE starting issues

#4 Post by Cromp85 » Thu Feb 13, 2020 7:38 pm

GTiJohn wrote:
Thu Feb 13, 2020 6:25 pm
216SE = SD3?

if so, it's an S-series...
Good point, I took 216 SE as meaning R8 SEi :slapme
Unfortunately I dont have any knowledge of S series engines. At a guess, i would think the electrics are more related to the late Maestros & Montegos.
My Rovers to date:
1994 Rover 220GSI in Tahiti blue (On the road)
2002 MG ZR 105 in Solar red (On loan)
1995 214i (On SORN)

220 GSi turbo
Events Secretary
Posts: 2012
Joined: Thu Sep 20, 2007 7:48 pm
Location: The National Forest

Re: Rover 216 SE starting issues

#5 Post by 220 GSi turbo » Thu Feb 13, 2020 11:04 pm

I would assume that a 216 SE would be an SD3, so as mentioned by others here, it will be the S-series engine as also used in the Maestro and Montego.

I can't remember if all SEs were fuel injected (Lucas EFi, like the MG Maestro 2.0) or if some of the earlier ones had a carburettor.

Could you clarify what you mean by "firing, but not starting"?

If it is an EFi system and the engine runs for a second and then stops, it is likely to be caused by one of the fuel pump relays.
1995 220GSi Turbo: owned for 18 years
1994 216SLi
2000 25GTi

Daily: ZR Trophy TD

Previously: 216 Coupe L887PTR(1993-95) 214SLi N219EPO(1995-96) 420GSi Turbo L955UKV(1997-2004) 214SEi M884BMR(2004-11) 420GSi Tourer M650XEX(2005-6) 214 SEi M103BCW(2011-12)

220 GSi turbo
Events Secretary
Posts: 2012
Joined: Thu Sep 20, 2007 7:48 pm
Location: The National Forest

Re: Rover 216 SE starting issues

#6 Post by 220 GSi turbo » Fri Feb 14, 2020 8:46 pm

Having just read your edit to your original post stating that it is a Honda engine, I guess your car must be an 'R8' after all.......maybe a 216 SE cabriolet?

Hopefully one of our Honda experts will be along soon :wink3
1995 220GSi Turbo: owned for 18 years
1994 216SLi
2000 25GTi

Daily: ZR Trophy TD

Previously: 216 Coupe L887PTR(1993-95) 214SLi N219EPO(1995-96) 420GSi Turbo L955UKV(1997-2004) 214SEi M884BMR(2004-11) 420GSi Tourer M650XEX(2005-6) 214 SEi M103BCW(2011-12)

richard moss
Club Member
Posts: 768
Joined: Sat Dec 22, 2007 12:02 am
Location: Al Ain, Abu Dhabi

Re: Rover 216 SE starting issues

#7 Post by richard moss » Sat Feb 15, 2020 4:09 am

If it IS a Honda engine, then the obvious starting point (sorry) is inspecting the inside of the main relay unit for broken solder joints and resoldering them.

Actually, it's worth resoldering them all anyway
Out in the desert with 2 old Jeeps and a Saab 9-3 cabrio
Back home: wife's 1993 216 DOHC Cabriolet, daughter's R100 and my 1969 MGC GT

JEASPEKE
Club Member
Posts: 192
Joined: Thu Aug 15, 2013 2:20 pm
Location: Nottingham
Contact:

Re: Rover 216 SE starting issues

#8 Post by JEASPEKE » Sat Feb 15, 2020 10:30 pm

I wrote an article on testing the main relay in an issue of the Viking 2016 or 17 probably, have a look at back issues

User avatar
1234dist
Club Member
Posts: 6489
Joined: Fri Aug 26, 2011 9:08 pm
Location: Chapel of Dist, Manchester
Contact:

Re: Rover 216 SE starting issues

#9 Post by 1234dist » Sun Feb 16, 2020 7:32 am

richard moss wrote:
Sat Feb 15, 2020 4:09 am
If it IS a Honda engine, then the obvious starting point (sorry) is inspecting the inside of the main relay unit for broken solder joints and resoldering them.

Actually, it's worth resoldering them all anyway
Happy to offer this service if you send me the relay and return post.
Pastor @ Rover Revival NFP Garage
220 Coupe turbo K785OAT
218 VVC Cabriolet R220OVR
Mercedes C270 diesel P80CJM
620 SLI P267LOM HONDA

Post Reply