1989 216 GSi Honda D16 - Engine Stopped Firing

Having problems with your 200 or 400? This is the place for asking advice and help on technical problems. Resident experts will be on hand to help you keep your car in tip top condition

Moderator: Forum Staff

Post Reply
Message
Author
StubbornPatriot
Club Secretary
Posts: 399
Joined: Thu Sep 11, 2014 11:30 pm
Location: Northampton

1989 216 GSi Honda D16 - Engine Stopped Firing

#1 Post by StubbornPatriot » Sun Nov 17, 2019 9:29 am

I was driving out of the village last night and the engine just stopped firing. No previous symptoms, it was running perfectly ok and just stopped. When I connected a spare spark plug to one of the HT leads and rested it on the cam cover there was no spark when turning the engine, so I believe this is an electrical problem. I've swapped the Main relay over to a couple of spares and no difference. I've checked all the fuses linked to the ignition system and they're OK. I am assuming this is a problem with the coil or igniter and will try swapping these over for a couple of spares.

Any suggestions for other obvious candidates for this sudden failure?
1989 216GSI + 1990 216GSI + 1997 416 Tourer + Triumph T160V

StubbornPatriot
Club Secretary
Posts: 399
Joined: Thu Sep 11, 2014 11:30 pm
Location: Northampton

Re: 1989 216 GSi Honda D16 - Engine Stopped Firing

#2 Post by StubbornPatriot » Sun Nov 17, 2019 11:30 am

Coil changed. Rover running. Result!

Cheers,

Duncan
1989 216GSI + 1990 216GSI + 1997 416 Tourer + Triumph T160V

User avatar
Johnny 216GSi
Club Treasurer
Posts: 2470
Joined: Wed Nov 19, 2014 10:17 pm
Location: Birmingham - the home of Rover!

Re: 1989 216 GSi Honda D16 - Engine Stopped Firing

#3 Post by Johnny 216GSi » Sun Nov 17, 2019 12:57 pm

StubbornPatriot wrote:
Sun Nov 17, 2019 11:30 am
Coil changed. Rover running. Result!

Cheers,

Duncan
Did you change the coil or the spark amplifier (or both)?
Rover 216GSi K reg. Flame Red over Tempest Grey

Image Image

StubbornPatriot
Club Secretary
Posts: 399
Joined: Thu Sep 11, 2014 11:30 pm
Location: Northampton

Re: 1989 216 GSi Honda D16 - Engine Stopped Firing

#4 Post by StubbornPatriot » Sun Nov 17, 2019 1:06 pm

Just the coil (replaced it with an old one from a spare D16 engine). Is Spark Amplifier a different term for Ignition Module?

As a matter of interest, is the coil suddenly failing a symptom of some other problem, or the cause in its own right? Why would a coil suddenly give up?

and last night I was "pushing this Rover".
1989 216GSI + 1990 216GSI + 1997 416 Tourer + Triumph T160V

Post Reply